[WARNING]: Could not match supplied host pattern, ignoring: unprovisioned PLAY [Deploy initial device configuration] ************************************* TASK [Set variables that cannot be set with VARS] ****************************** ok: [x1] ok: [x2] ok: [x3] ok: [dut] TASK [Find device readiness script] ******************************************** ok: [x1] ok: [x2] ok: [x3] ok: [dut] TASK [Wait for device to become ready] ***************************************** skipping: [x1] skipping: [x2] skipping: [x3] included: /home/pipi/net101/tools/netsim/ansible/tasks/readiness-check/routeros7.yml for dut TASK [Execute local ssh command to check router readiness] ********************* skipping: [dut] TASK [Normalize config on bridge-like devices] ********************************* included: /home/pipi/net101/tools/netsim/ansible/tasks/deploy-module.yml for x1, x2, x3, dut TASK [Figure out whether to deploy the module normalize on current device] ***** ok: [x1] ok: [x2] ok: [x3] ok: [dut] TASK [Find configuration template for normalize] ******************************* ok: [x1] ok: [x2] ok: [x3] ok: [dut] TASK [fail] ******************************************************************** skipping: [x1] skipping: [x2] skipping: [x3] skipping: [dut] TASK [Print deployed configuration when running in verbose mode] *************** skipping: [x1] skipping: [x2] skipping: [x3] skipping: [dut] TASK [Find configuration deployment deploy_script for normalize] *************** skipping: [x1] skipping: [x2] skipping: [x3] skipping: [dut] TASK [Deploy normalize configuration] ****************************************** skipping: [x1] skipping: [x2] skipping: [x3] skipping: [dut] TASK [Deploy initial configuration] ******************************************** included: /home/pipi/net101/tools/netsim/ansible/tasks/deploy-module.yml for x1, x2, x3, dut TASK [Figure out whether to deploy the module initial on current device] ******* ok: [x1] ok: [x2] ok: [x3] ok: [dut] TASK [Find configuration template for initial] ********************************* ok: [x1] ok: [x2] ok: [x3] ok: [dut] TASK [fail] ******************************************************************** skipping: [x1] skipping: [x2] skipping: [x3] skipping: [dut] TASK [Print deployed configuration when running in verbose mode] *************** ok: [dut] => msg: |- initial configuration for dut ========================================= /system identity set name="dut" /interface bridge add name=loopback protocol-mode=none /ip address add interface=loopback address=10.0.0.1/32 /interface/bridge/add name=switch vlan-filtering=yes comment="Global Switch Bridge" /interface/vlan/add name=vlan500 vlan-id=500 interface=switch /interface/vlan/add name=vlan501 vlan-id=501 interface=switch /interface/vlan/add name=vlan502 vlan-id=502 interface=switch /interface ethernet set comment="dut -> x3" ether2 /interface ethernet set mtu=1400 ether2 /interface ethernet set comment="[Access VLAN ospf_1] dut -> x1" ether3 /interface ethernet set mtu=1400 ether3 /interface ethernet set comment="[Access VLAN ospf_2] dut -> x2" ether4 /interface ethernet set mtu=1280 ether4 /interface ethernet set comment="VLAN ospf_1 (500) -> [x1]" vlan500 /interface ethernet set mtu=1400 vlan500 /ip address add interface=vlan500 address=172.16.0.1/24 /ip address set [find where interface=vlan500] comment="VLAN ospf_1 (500) -> [x1]" /interface ethernet set comment="VLAN ospf_2 (501) -> [x2]" vlan501 /interface ethernet set mtu=1280 vlan501 /ip address add interface=vlan501 address=172.16.1.1/24 /ip address set [find where interface=vlan501] comment="VLAN ospf_2 (501) -> [x2]" /interface ethernet set comment="VLAN ospf_3 (502) -> [x3]" vlan502 /interface ethernet set mtu=1320 vlan502 /ip address add interface=vlan502 address=172.16.2.1/24 /ip address set [find where interface=vlan502] comment="VLAN ospf_3 (502) -> [x3]" /ip neighbor discovery-settings set discover-interface-list=all ok: [x1] => msg: |- initial configuration for x1 ========================================= #!/bin/bash # set -e set -x # # Create bash profile script # cat <