[WARNING]: Could not match supplied host pattern, ignoring: unprovisioned PLAY [Deploy initial device configuration] ************************************* TASK [Set variables that cannot be set with VARS] ****************************** ok: [pe2] ok: [p1] ok: [p2] ok: [h2] ok: [dut] ok: [h1] TASK [Find device readiness script] ******************************************** ok: [pe2] ok: [p1] ok: [p2] ok: [h1] ok: [dut] ok: [h2] TASK [Wait for device to become ready] ***************************************** skipping: [pe2] skipping: [p1] skipping: [p2] skipping: [h1] skipping: [h2] included: /home/pipi/net101/tools/netsim/ansible/tasks/readiness-check/routeros7.yml for dut TASK [Execute local ssh command to check router readiness] ********************* skipping: [dut] TASK [Deploy initial configuration] ******************************************** included: /home/pipi/net101/tools/netsim/ansible/tasks/deploy-module.yml for dut, pe2, p1, p2, h1, h2 TASK [Figure out whether to deploy the module initial on current device] ******* ok: [pe2] ok: [p1] ok: [p2] ok: [h1] ok: [dut] ok: [h2] TASK [Find configuration template for initial] ********************************* ok: [pe2] ok: [p1] ok: [p2] ok: [dut] ok: [h2] ok: [h1] TASK [Print deployed configuration when running in verbose mode] *************** ok: [dut] => msg: |- initial configuration for dut ========================================= /system identity set name="dut" /interface bridge add name=loopback protocol-mode=none /ip address add interface=loopback address=10.0.0.3/32 /interface ethernet set comment="dut -> h1 [stub]" ether2 /ip address add interface=ether2 address=172.16.0.3/24 /ip address set [find where interface=ether2] comment="dut -> h1 [stub]" /interface ethernet set comment="dut -> p1" ether3 /ip address add interface=ether3 address=172.16.1.3/24 /ip address set [find where interface=ether3] comment="dut -> p1" /ip neighbor discovery-settings set discover-interface-list=all ok: [pe2] => msg: |- initial configuration for pe2 ========================================= #!/bin/bash # set -e set -x # # Create bash profile script # cat <